# Notification.
Notification

Author Topic: รบกวนครับ ปัญหาเกี่ยวกับ Blue screen  (Read 3400 times)

0 Members and 1 Guest are viewing this topic.

Offline Roman43

  • VPC Member
  • **
  • Posts: 23
    • View Profile
ประกอบคอมใช้งานมาเดือนกว่า ๆ ครับ พบปัญหา Blue screen อยู่เรื่อย ๆ ครับ พยายามหาข้อมูลค่อย ๆ หาต้นเหตุตลอดครับ จนสุดท้ายไม่แน่ใจ จึงต้องมาขอรบกวนสอบถามครับ
ข้ออนุญาตลงรูปจากโปรแกรมโชว์จอฟ้านะครับ (ได้โปรแกรมนี้มาแบบบังเอิญจากการพยายามแก้ปัญหาเองครับ ผมว่าเป็นโปรแกรมที่จะช่วยให้หาสาเหตได้พอสมควรเลยครับ แต่ถ้าค้นเรื่องจอฟ้า จะไม่ค่อยเห็นโปรแกรมนี้เลยครับ มีแต่แนะนำให้ติ๊กออโตรีสตาร์ทออก แล้วก็ดูตอนเกิดเหตจอฟ้าจำโค๊ดมาหาต่ออีกที ผมจึงขออนุญาตแนะนำสำหรับท่านที่มีปัญหาจอฟ้านะครับ ให้ลองเซิร์ช BlueScreenView ดูครับ)


เสปกเครื่องนี้นะครับ
i5-3570K ไม่ได้ Overclock ครับ
Gigabyte Z77X-D3H [bios Ver.F15]
Team Xtreem LV2133 8g ตั้ง xmp 1.3
SSD vector 120g
WD blue 1T, 500g
Corsair H100i
Corsair TX650M
APC back-UPS XS 1100CI
Win7 SP1 Ulti 64bit
ในตอนแรกยังไม่เจอโปรแกรมโชว์จอฟ้า ยังดูโค๊ดทันบ้างไม่ทันบ้าง ก็คลำ ๆ ตามที่หาข้อมูลมา
สังเกตการใช้งานส่วนใหญ่ตอนเป็นจอฟ้า ผมจะเปิด Chrome รวม ๆ ก็ 20 กว่าแท็บได้ครับ พร้อมโหลดบิท โหลดธรรมดา ฟังเพลง หรือไม่ก็ดูอนิเมะบ้าง
เลยคิดว่าปัญหาน่าจะอยู่แถว ๆ แรม, SSD ไม่ก็ bad sector ใน HDD
 
-เช็คแรม จากโปรแกรมเทสแรมของวินโดว์เอง ตั้งทดสอบไปสี่รอบ ใช่เวลาราว ๆ หนึ่งชั่วโมง ก็ผ่านปกติดี
-เช็ค SSD อีกครั้ง ดู diver ก็ลงถูกแล้ว เช็คสภาพด้วยโปรแกรมก็โอเค
-เช็ค bad sector ใน HDD ก็ไม่พบครับ

จนได้โค๊ดมา เห็นมีเกี่ยวกับ IRQ ก็ลองหาข้อมูลดู ผมก็เลยมาเอะใจ ยังมีอีกโปรแกรมที่ผมจะเปิดใช้ทุกครั้งเมื่อเปิดคอมคือ TCP-Z แก่ค่า half-open ครับ 

จากแหล่งที่ได้มา เหมือนกับว่าโปรแกรมนี้จะช่วยให้ใช้เน็ทเร็วขึ้นเวลาที่เราโหลดบิทไปด้วย ผมเลยลองไม่ใช้โปรแกรมนี้
คิดว่าเดามาถูกทางแล้วครับ แต่ยังครับ วันนี้แค่ก๊อปข้อมูลไป WD green 2T ไม่ได้เปิดโปรแกรมอะไรเลย มีแค่ IE ที่ผมเปิดแท็บเดียวเพื่อใช้เช็คข้อมูลกับไฟล์ที่ก๊อปอยู่ครับ
ปรากฎว่าก็ยังเกิดจอฟ้าอยู่ครับ  [emo08] [emo08] เป็นบ่อย ๆ ผมก็เริ่มจะจิตตกแล้วหละครับ แถมเป็นตอนก๊อปข้อมูลซะด้วย ต้องขอความกรุณาช่วยเหลือด้วยครับ
คำถามครับ
1. ในตอนนี้ก็ยังคิดว่าเป็นปัญหาที่เกิดจาก โปรกแกรม TCP-Z อยู่ครับ แต่ผมไม่ได้เปิดใช้เลยนะครับ เป็นไปได้ไหมว่าเคยเปิดใช้แล้ว มันยังไปกวนระบบในวินโดว์อยู่
ถ้าสมมุติว่าใช่ แล้วผมจะแก้ปัญหาได้อย่างไรครับ โดยที่ไม่อยากลงวินโดว์ใหม่นะครับ จะสามารถทำได้หรือเปล่าครับ
2. แล้วเจ้าไฟล์ ntoskrnl.exe คือไฟล์อะไรครับผม
3. อุณหภมูิแรมจะมีโปรแกรมเช็คได้ไหมครับ
4. M/B กับ แรม ชุดนี้สามารถใช้ด้วยกันได้หรือเปล่าครับ เข้าไปดูเว็บ Gig เห็นว่าใช้ได้กับแรม 2800 OC แล้วก็ไป 1600 1333 เลย

รบกวนด้วยครับ ถ้าต้องการข้อมูลอะไรเพิ่มเติมอีก ยินดีบอกหมดครับ ที่พิมพ์ไปซะเยอะ คือเผื่อมีประโยชน์ในการหาปัญหาบ้างหนะครับ
ปล.ขนาดพิมพ์ถามอยู่นี่ยังเกิดจอฟ้าเลยครับ ตามเวลาที่โชว์ในรูปนั้นเลยครับ  [emo14] [emo14]

Offline microsoft

  • Administrator
  • *****
  • Posts: 8651
    • View Profile
    • VarietyPC.Net
จากอาการที่ว่ามา ถ้าให้ไล่เช็คด้วยซอฟท์แวร์ช่วยดังกล่าว ผมไม่ค่อยถนัดครับ ต้องทดสอบหาอาการไปเรื่อยๆ ไล่เช็คฮาร์ดแวร์ทุกชิ้น แต่ช่วงท้ายๆที่ท่านบอกมา ตอนนี้ผมมุ่งประเด็นปัญหาไปที่แรมกับเมนบอร์ดครับ แต่สงสัยที่แรมมากกว่า เพราะที่แน่ๆอาการ blue screen ดังกล่าว มักมีปัญหาตอนที่ก็อบปี้ไฟล์ ดังนั้น เราก็ไล่เปลี่ยนอุปกรณ์พร้อมกับทดสอบด้วยการก็อบปี้ไฟล์นี่แหละ แต่ต้องพึ่งความใจเย็นเข้ามาช่วยด้วยนะครับ เพราะอาการนานๆเจอทีนี่ต้องใช้เวลาหาต้นตอพอสมควร ก็ลองทำตามนี้

1. ลองใช้ค่า default ของแรมดูก่อนก็คือบัส 1333 แล้วลองก็อบปี้ไฟล์ไปเรื่อยๆว่ามีปัญหามั้ย ถ้ายังมีปัญหา ก็ลองปรับเป็นบัส 1600 ค่าบัสสูงสุดควรตรึงไว้แค่นี้ เพราะบอร์ดรองรับบัสสูงสุดแบบไม่ OC ที่ 1600 ครับ และค่า vRam ปรับไฟเป็น Auto

2. แรมตามสเปคท่านเป็นขนาด 8GB แต่ไม่ทราบว่าเป็น 8GB 1 แถว หรือ 4GB 2 แถวครับ ซึ่งถ้าเป็น 4GB 2 แถวนี่ ก็ง่ายขึ้นมาอีกนิด โดยอยากให้ลองถอดออก 1 แถว แล้วใช้งานแค่ 1 แถว และทำการทดสอบก็อบปี้ไฟล์ หากยังเป็นก็สลับเอาอีกแถวมาเสียบ แล้วทดสอบเหมือนเดิม แต่ถ้าเป็น 8GB 1 แถว ก็ต้องพึ่งข้อ 3

note. ข้อ 1 กับ 2 จะทำข้อไหนก่อนก็ได้

3. อาจเป็นที่แรมกับเมนบอร์ดไม่เข้ากัน ก็คงต้องลองแฟลชไบออส ให้เป็นเวอร์ชั่น F16 หรือ F17f (เวอร์ชั่น beta)

ปล. เท่าที่ผมลองเช็ครายการแรมที่รองรับกับเมนบอร์ดรุ่นนี้ สำหรับยี่ห้อ Team ตามสเปคจะระบุเอาไว้ว่าต้องเป็นขนาด 1GB DDR3-2000, 2GB DDR3-1600 และ 2GB DDR3-1333 เท่านั้น แต่แรมตามสเปคท่านเป็นบัส 2133 และมีขนาด 8GB ก็เป็นไปได้ว่า สเปคแรมไม่รองรับกับเมนบอร์ดได้ด้วยเหมือนกันนะครับ คงต้องลองแฟลชไบออสดู  [emo04]
การให้ที่ยิ่งใหญ่ คือ... การให้ต่อไป.... ไม่สิ้นสุด

Offline Roman43

  • VPC Member
  • **
  • Posts: 23
    • View Profile
ขอบคุณมาก ๆ ครับ เดียวจะลองไล่เช็คดูครับ

ปล. แรมเป็นแบบ 4x2 ครับ

แก้ไข เพิ่มคำถามครับผม

โปรแกรม windows memory diagnostic ใช้ทดสอบปัญหาของแรมได้หรือเปล่าครับ

Offline microsoft

  • Administrator
  • *****
  • Posts: 8651
    • View Profile
    • VarietyPC.Net
ใช้ได้ครับ และเอา GoldMemory ที่มีในแผ่น hiren's bootcd ช่วยทดสอบด้วยก็ได้ครับ  [emo02]

ฝากกระทู้ด้วยนะครับ ตอนนี้ผมกำลังทยอยตรวจทานทุกกระทู้ กระทู้ไหนที่ได้รับคำแนะนำจนสามารถแก้ไขได้เป็นผลสำเร็จ อาจจะด้วยคำแนะนำที่เป็นไปได้ หรือด้วยคำแนะนำที่เคยเจอจากประสบการณ์จากเพื่อนๆทุกท่าน หรือผมเองที่อาจจะพอรู้บ้าง ผมจะทยอยติ๊กเครื่องหมายถูกให้ เพื่อท่านอื่นๆเจอปัญหาจะได้แก้ไขได้ด้วยครับ  [emo04]
การให้ที่ยิ่งใหญ่ คือ... การให้ต่อไป.... ไม่สิ้นสุด

Offline Roman43

  • VPC Member
  • **
  • Posts: 23
    • View Profile
กลับมารายงานผลครับ

1. เรื่องแรมกับเมนบอร์ดครับ ได้ไปถามที่เว็ป OCZ ดูครับ ที่ bus 2133 มีคนใช้กับบอร์ดนี้ Z77X-D3H ไม่เกิดปัญหาจอฟ้าครับ และมีอีกท่านหนึ่ง ที่มีเมนบอร์ดกับแรมตัวเดียวกับของผม แต่เป็นไบออส F16 ครับ ใช้งานไม่เกิดจอฟ้าครับ แสดงว่าเมนบอร์ดตัวนี้น่าจะรับกับ bus 2133 ได้ครับ
2. windows memory diagnostic เทส 4 ครั้งผ่านครับ (ทำตั้งแต่ครั้งแรก ๆ ที่พอจอฟ้าแล้วครับ) และ memtest86 ใน hiren's bootcd (ตัวล่าสุดครับผมโหลดจากทางเว็บเลย พึ่งจะมีแผ่น hiren's bootcd นี่หละครับ แต่ไม่เห็น GoldMemory ที่คุณ  microsoft แนะนำในแผ่นนะครับ) เทส 1 ครั้งก็ผ่านครับ

ขออนุญาตเล่าไปตามที่เจอปัญหานะครับ
ลงวินโดว์ใหม่ครั้งที่ 1 พบจอฟ้าสองคร้ง ในขณะที่โหลดอัพเดตวินโดว์ (ดูโค๊ตไม่ทันครับ) ต่อมาลงโปรแกรมอยู่ครับ เป็น 0x0000001A Memory_Management ครับ สงสัยแรมอย่างมากครับในขณะนั้น
แต่จำเป็นต้องใช้งานก่อนครับเลยกัดฟันลงวินโดว์อีกครั้ง เกิดจอฟ้า 0x0000000A ครับ หาข้อมูลคิดว่าน่าจะเกิดปัญหาจากตัววินโดว์เอง ขออนุญาตลงลิงค์นะครับ http://siamtrick.blogspot.com/2010/02/windows-7-bsod.html ผมก็ลงฮอตฟิกซ์ตามที่เว็บนั้นแนะนำครับ
หลังจากนั้นมีเวลา ก็เริ่มเทสแรมด้วย memtest86 ครับ อย่างที่บอกไปด้านบนครับ ไม่พบ error ครับ
***หลังจากอัพไบออสเป็น F16 และยังไม่อัพเดตวินโดว์ ใช้งานมาสองวันแล้วยังไม่พอจอฟ้าครับ

สอบถามครับ
1.windows memory diagnostic และ memtest86 สามารถใช้เช็คปัญหาแรมเสียได้จริง ๆ หรือเปล่าครับ เพราะว่าผมเทสผ่าน แต่เห็นโค๊ดจอฟ้าส่วนใหญ่ของผม เกี่ยวกับแรมทั้งนั้นเลยครับ
2.ผมทำตามที่คุณ microsoft แนะนำตามข้อหนึ่งแล้วนะครับไม่มีปัญหาครับ แต่ขอสองผมยังไม่ได้ลองครับ คือถ้าผมใช้ตัวเทสด้านบนทั้งสองอย่างนี้แล้ว จะพอพิสูจน์ว่าแรมไม่เสียโดยที่ไม่ต้องทำตามข้อสองได้หรือเปล่าครับ (คือผมถามในกรณีอื่น ๆ ด้วยนะครับ ประมาณอยากทราบว่าใช้ตัวเทสกับการเทสโดยถอดแรม สามารถแทนกันได้ไหม)
3.การ์ดจอออน CPU ที่เป็น HD4000 มีแรมในตัวหรือเปล่า คือที่หาข้อมูลมา นอกจากแรมแล้ว แรมบนการ์ดจอก็อาจทำให้เกิดจอฟ้าด้วยครับ และตอนนี้ผมอัพเดตไดเวอร์การ์ดจอ HD4000 เป็นตัวล่าสุดด้วยครับยังไม่พบจอฟ้าครับ ส่วนปัญหาก่อนหน้านี้อาจจะเป็นที่ แรมกับไดเวอร์การ์ดจอหรือเปล่าครับ

ตอนนี้ยังไม่พบปัญหานะครับ คาดว่าน่าจะเป็นจากการอัพไบออส กับอัพไดเวอร์การ์จอ และสุดท้ายตอนนี้ยังไม่อัพเดตวินโดว์ตัวที่เป็นส่วนการแก้ไขของวินโดว์นะครับ
เนื่องจากเคยอ่านมาว่า ตัวแก้ไขของวินโดว์เองก็อาจเป็นสาเหตของจอฟ้าได้ครับ เช่นไฟล์ ntoskrnl.exe ผมหาข้อมูลมาเคยมีคนเป็นจอฟ้าเนื่องจากตัวแก้ไขวินโดว์ที่ให้เราอัพเดตครับ แต่เป็นบ้างเครื่องนะครับ เดี๋ยวผมจะลองใช้งานดูก่อน หลังจากนั้นจะอัพเดตวินโดว์ตามปกติ ถ้าไม่พบก็จะเหลือแค่ผู้ต้องสังสัย คือการอัพไบออสกับ อัพไดเวอร์การ์ดจอครับ

ขอบคุณที่ให้ความช่วยเหลือนะครับ ที่ผมพิมพ์ไปซะเยอะ คือเพื่อมีท่านไหนมีปัญหาเช่นเดียวกันจะได้พอมีแนวทางบ้างครับ เพราะผมหาข้อมูลส่วนใหญ่ พบแต่เว็บต่างประเทศ ก็คลำ ๆ แปลไปครับ  [emo14] 
   

Offline microsoft

  • Administrator
  • *****
  • Posts: 8651
    • View Profile
    • VarietyPC.Net
Quote
1.windows memory diagnostic และ memtest86 สามารถใช้เช็คปัญหาแรมเสียได้จริง ๆ หรือเปล่าครับ เพราะว่าผมเทสผ่าน แต่เห็นโค๊ดจอฟ้าส่วนใหญ่ของผม เกี่ยวกับแรมทั้งนั้นเลยครับ
2.ผมทำตามที่คุณ microsoft แนะนำตามข้อหนึ่งแล้วนะครับไม่มีปัญหาครับ แต่ขอสองผมยังไม่ได้ลองครับ คือถ้าผมใช้ตัวเทสด้านบนทั้งสองอย่างนี้แล้ว จะพอพิสูจน์ว่าแรมไม่เสียโดยที่ไม่ต้องทำตามข้อสองได้หรือเปล่าครับ (คือผมถามในกรณีอื่น ๆ ด้วยนะครับ ประมาณอยากทราบว่าใช้ตัวเทสกับการเทสโดยถอดแรม สามารถแทนกันได้ไหม)

ไม่เสมอไปครับ ไม่แน่นอน บางทีใช้ซอฟท์แวร์ตัวดังกล่าวทดสอบ ก็ยากที่จะหาเจอว่า ต้องลองใช้งานกับซอฟท์แวร์ทั่วไปด้วย เพราะบางทีอาการเกิดทีนี่ต้องค่อยๆหา (อาการนานๆเจอทีนี่ผมก็เบื่อมากๆ เพราะไม่รู้เมื่อไรมันจะเกิด)

Quote
3.การ์ดจอออน CPU ที่เป็น HD4000 มีแรมในตัวหรือเปล่า คือที่หาข้อมูลมา นอกจากแรมแล้ว แรมบนการ์ดจอก็อาจทำให้เกิดจอฟ้าด้วยครับ และตอนนี้ผมอัพเดตไดเวอร์การ์ดจอ HD4000 เป็นตัวล่าสุดด้วยครับยังไม่พบจอฟ้าครับ ส่วนปัญหาก่อนหน้านี้อาจจะเป็นที่ แรมกับไดเวอร์การ์ดจอหรือเปล่าครับ

ในตัวจะไม่มีแรมมาให้ครับ แต่ถ้าหากจะใช้งานแบบไม่มีการ์ดจอแยก ระบบก็จะดึงเอาพื้นที่ของแรมในเครื่องมาใช้งาน แต่ถ้าต่อการ์ดจอแยก ส่วนนี้จะโดนตัดออกอัตโนมัติ

เป็นไปได้อยากให้ลองแฟลชไบออสดูด้วยครับ อยากรู้เหมือนกันว่า จะดีขึ้นหรือมีอาการอยู่เหมือนเดิมครับ
การให้ที่ยิ่งใหญ่ คือ... การให้ต่อไป.... ไม่สิ้นสุด

Offline Roman43

  • VPC Member
  • **
  • Posts: 23
    • View Profile
แฟลชไบออสเป็น F16 แล้วครับผม ต้องข้อโทษด้วยครับ ใช้คำผิด ไปพิมพ์ว่าอัพไบออส
หลังจากแฟลชไบออสแล้วยังไม่พบอาการจอฟ้าครับผม

Offline microsoft

  • Administrator
  • *****
  • Posts: 8651
    • View Profile
    • VarietyPC.Net
ใช้คำยังไงก็ได้ครับ อัพไบออส ก็คือ อัพเดตไบออส แต่ผมเรียก แฟลชไบออส มาเสียจนติดปาก  [emo04]
การให้ที่ยิ่งใหญ่ คือ... การให้ต่อไป.... ไม่สิ้นสุด


 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27